Our projects

TD Azlan for iPhone


You can download the app from your local App Store by searching for 'Azlan' in;

- Austria
- Belgium
- Czech Republic
- Denmark
- Finland
- France
- Germany
- Ireland
- Italy
- Luxemburg
- Netherlands
- Norway
- Poland
- Portugal
- Spain
- Sweden
- Switserland
- United Kingdom

TD Azlan for BlackBerry

You are currently using a non BlackBerry. The BlackBerry browser is required for the installation of the TD Azlan App for BlackBerry.

Minimum requirements

  • BlackBerry OS 4.5 or above
  • BlackBerry browser
Supported Devices
  • BlackBerry Bold
  • BlackBerry Curve
Installation Instructions
  • Please visit this webpage with your BlackBerry phone